Well this is embarrassing...
You're currently on a web browser that does not support the most recent version of the CSS Flexible Box Model.
Upgrade your browser and have a nice day!

Safari 7+

Internet Explorer 11

Chrome 29+

Opera 12.1

Safari 6.1+ prefixed

Chrome 21+

Firefox 23+


View full table of support for Flexbox on Can I use...
Lorem ipsum
dolor
sit
amet
consectetur
adipiscing elit
nunc
enim
nunc
volutpat eget
aliquam
nec
accumsan rutrum
bacon
maecenas
nunc
voldermere
it
las
quid
tostidos
gray

Flexbox support (July 2014):

IE 11+ unprefixed

Chrome 29+ unprefixed

Firefox 28+ unprefixed

Opera 12.1+ unprefixed

Safari 6.1+ prefixed

Safari 6.1+ prefixed

Google